aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mycli/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mycli/APKBUILD')
-rw-r--r--testing/mycli/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/mycli/APKBUILD b/testing/mycli/APKBUILD
deleted file mode 100644
index dd5bd735499..00000000000
--- a/testing/mycli/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Thomas Boerger <thomas@webhippie.de>
-# Maintainer: Thomas Boerger <thomas@webhippie.de>
-pkgname=mycli
-pkgver=1.22.2
-pkgrel=0
-pkgdesc="MySQL CLI with autocompletion and syntax highlighting"
-url="https://www.mycli.net"
-arch="noarch"
-license="BSD-3-Clause"
-depends="python3
- py3-click
- py3-pygments
- py3-prompt_toolkit>2.0.5
- py3-pymysql
- py3-sqlparse<0.4.0
- py3-configobj
- py3-cryptography
- py3-cli_helpers"
-makedepends="python3-dev py3-setuptools py3-paramiko"
-checkdepends="py3-pytest py3-mock"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/m/mycli/mycli-$pkgver.tar.gz"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 -m pytest -v test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="a90ab1b4ee95d1a7c915cd537ccbc1de9030e44e7b240b1e7c12766d09b03c3922705e20fdf7616350829d72508a8b9f2932389957744fe58d299acccdce240b mycli-1.22.2.tar.gz"