aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nicotine-plus/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/nicotine-plus/APKBUILD')
-rw-r--r--testing/nicotine-plus/APKBUILD34
1 files changed, 27 insertions, 7 deletions
diff --git a/testing/nicotine-plus/APKBUILD b/testing/nicotine-plus/APKBUILD
index fe14f676f20..340990fc2a3 100644
--- a/testing/nicotine-plus/APKBUILD
+++ b/testing/nicotine-plus/APKBUILD
@@ -1,21 +1,41 @@
# Contributor: dai9ah <dai9ah@protonmail.com>
# Maintainer: dai9ah <dai9ah@protonmail.com>
pkgname=nicotine-plus
-pkgver=3.1.0
-pkgrel=0
+pkgver=3.3.2
+pkgrel=1
pkgdesc="Graphical client for the SoulSeek peer-to-peer system"
url="https://nicotine-plus.github.io/nicotine-plus"
arch="noarch"
license="GPL-3.0-or-later"
-depends="gtk+3.0 py3-gobject3 python3"
-makedepends="gettext"
-subpackages="$pkgname-doc $pkgname-lang"
+depends="gtk+3.0 py3-gobject3 python3 python3-gdbm"
+makedepends="py3-gpep517 py3-setuptools py3-wheel gettext"
+checkdepends="py3-pytest"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-pyc"
source="nicotine-plus-$pkgver.tar.gz::https://github.com/Nicotine-Plus/nicotine-plus/archive/$pkgver.tar.gz"
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m pytest \
+ --deselect pynicotine/tests/integration/test_startup.py::StartupTest::test_gui_startup
+}
+
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+lang() {
+ pkgdesc="Languages for package $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel lang"
+
+ amove usr/lib/python*/site-packages/pynicotine/locale
}
sha512sums="
-355bb6dfc7fcd9d8c6b04ab2f4f563fb7d80781cb7d7c437d577799e404fe6aef66942d138f889849740ade80ffd9c8927db182821d0b746e185d8bea4f004aa nicotine-plus-3.1.0.tar.gz
+590886c24104e47c1cd72fb0c03bc0a87f33f7ecdb6349b2fef354aa22a6417bcf002b2d1083b383bdc2ca4f35200f3997af7f8c552658ca9defec2958510cd8 nicotine-plus-3.3.2.tar.gz
"