aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nlopt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/nlopt/APKBUILD')
-rw-r--r--testing/nlopt/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/nlopt/APKBUILD b/testing/nlopt/APKBUILD
new file mode 100644
index 00000000000..0be29fe46b0
--- /dev/null
+++ b/testing/nlopt/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Anjandev Momi <anjan@momi.ca>
+# Maintainer: Anjandev Momi <anjan@momi.ca>
+pkgname=nlopt
+pkgver=2.7.1
+pkgrel=0
+pkgdesc="library for nonlinear optimization, wrapping many algorithms for global and local, constrained or unconstrained, optimization"
+url="https://github.com/stevengj/nlopt/"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="samurai cmake"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/stevengj/nlopt/archive/refs/tags/v$pkgver.tar.gz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=minsizerel \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+e23cb522fc696010574c14b72be85acc0f8ccf0bf208bf2b8789c57d6c5a6e6d419ee10330581518b1c1567018ae909b626ce7761d4fbd5bf112916871e420e2 nlopt-2.7.1.tar.gz
+"