aboutsummaryrefslogtreecommitdiffstats
path: root/testing/noson-app/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/noson-app/APKBUILD')
-rw-r--r--testing/noson-app/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/testing/noson-app/APKBUILD b/testing/noson-app/APKBUILD
index a851523cdad..c56108e92be 100644
--- a/testing/noson-app/APKBUILD
+++ b/testing/noson-app/APKBUILD
@@ -1,12 +1,16 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=noson-app
-pkgver=4.4.7
-pkgrel=0
+pkgver=5.4.1
+pkgrel=1
pkgdesc="The essential to control music from your SONOS devices on Linux platforms"
url="https://janbar.github.io/noson-app/"
-arch="all !armhf" # Missing Qt stuff
+# armhf: Missing Qt stuff
+# riscv64: truncated relocation
+arch="all !armhf !riscv64"
license="GPL-3.0-only"
+subpackages="$pkgname-dbg"
+depends="qt5-qtsvg"
makedepends="
cmake
flac-dev
@@ -16,6 +20,7 @@ makedepends="
qt5-qtdeclarative-dev
qt5-qtquickcontrols2-dev
qt5-qtsvg-dev
+ samurai
"
source="
$pkgname-$pkgver.tar.gz::https://github.com/janbar/noson-app/archive/$pkgver.tar.gz
@@ -23,18 +28,20 @@ source="
options="!check" # No unit tests
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=1 \
-DBUILD_DEPENDENCIES=0 \
-DBUILD_LIBNOSON=0
- make -C build
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir" install -C build
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="33b9651dd27f6b6a614658fdc8a3ed0efb3adc003c7d431a3732743132a5e6a9385370cf639877dbdcf1636f781c7e4ebf1fab3cb2b41f0000e23ced3d0eebd8 noson-app-4.4.7.tar.gz"
+sha512sums="
+dbddb96f3e0720c3d9306d34466575d64be622250345ff0d45589abbdfc6f4a777a3fe1314c023ac5240b208f865dd7886c8ef206bb81b85262e5172a72f9441 noson-app-5.4.1.tar.gz
+"