aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nushell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/nushell/APKBUILD')
-rw-r--r--testing/nushell/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/testing/nushell/APKBUILD b/testing/nushell/APKBUILD
deleted file mode 100644
index 67e5279fa5d..00000000000
--- a/testing/nushell/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: nibon7 <nibon7@163.com>
-# Maintainer: nibon7 <nibon7@163.com>
-pkgname=nushell
-pkgver=0.40.0
-pkgrel=1
-pkgdesc="A new type of shell"
-url="https://www.nushell.sh"
-# s390x, mips, mips64: limited by cargo
-arch="all !s390x !mips !mips64 !riscv64"
-license="MIT"
-makedepends="cargo pkgconf openssl1.1-compat-dev libx11-dev libxcb-dev libgit2-dev python3"
-install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
-source="$pkgname-$pkgver.tar.gz::https://github.com/nushell/nushell/archive/$pkgver.tar.gz
- 0001-remove-dataframe-feature-from-default.patch"
-
-# The parquet crate required by dataframe has some implementations that depend on specific architectures
-case "$CARCH" in
- aarch64 | arm* | x86*) _cargo_opts="--locked --features extra,dataframe" ;;
- *) _cargo_opts="--locked --features extra" ;;
-esac
-
-build() {
- cargo build --release $_cargo_opts
-}
-
-check() {
- # Some tests may timeout on armhf with release build
- cargo test $_cargo_opts
-}
-
-package() {
- cargo install $_cargo_opts --path . --root="$pkgdir/usr"
- rm "$pkgdir"/usr/.crates*
-}
-
-sha512sums="83e8382a524699bb8bca03b1262a4943eba9acd0e4855deb3556f03bbc53c643b4697dc7ffb09e9d9d05326d14f4101b793fea7f39bcb68ba10b532873a08daa nushell-0.40.0.tar.gz
-f1b87fd1b08641dd2526309806392cbd5267ffc1ee31569874f56217eb26e422994a5a4cce38335c0152775ca186bf75fd7890ec85a6b031cca06318e63dd035 0001-remove-dataframe-feature-from-default.patch"