aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-labltk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ocaml-labltk/APKBUILD')
-rw-r--r--testing/ocaml-labltk/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/testing/ocaml-labltk/APKBUILD b/testing/ocaml-labltk/APKBUILD
index 19a82c221eb..c6e34ce2854 100644
--- a/testing/ocaml-labltk/APKBUILD
+++ b/testing/ocaml-labltk/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-labltk
_pkgname=labltk
-pkgver=8.06.2
+pkgver=8.06.4
pkgrel=0
+_ocamlver=4.06
pkgdesc="Tcl/Tk interface for OCaml"
url="http://labltk.forge.ocamlcore.org/"
arch="all !x86 !armhf !s390x" # limited by ocaml aport
license="LGPL-2.0-or-later-WITH-linking-exception"
+depends="ocaml-runtime"
depends_dev="$pkgname=$pkgver-r$pkgrel"
-makedepends="ocaml>=4.04 tcl-dev tk tk-dev"
+makedepends="ocaml=~$_ocamlver ocaml-compiler-libs=~$_ocamlver tcl-dev tk tk-dev"
options="!check" # no tests provided
subpackages="$pkgname-dev"
-source="https://forge.ocamlcore.org/frs/download.php/1628/$_pkgname-$pkgver.tar.gz"
+source="https://forge.ocamlcore.org/frs/download.php/1727/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -53,4 +55,4 @@ dev() {
mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
}
-sha512sums="d9342d49ba8769edd7a4ed051844f6ae5d3e62a7c2c76e895bfd1162d0433c4ea54f2314b29b708551fba63daec1123553b56f0abb6412807ab00d7bb40b73d6 labltk-8.06.2.tar.gz"
+sha512sums="5221d2378f73cbcc2a4abd003023c01c8f0e1a919029ddb06069db30284b0bdef12e03b66b9c7c694c7a2128b060f2f2a5a34e4f3b8eed1060a0880a2e429644 labltk-8.06.4.tar.gz"