aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-lambda-term/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ocaml-lambda-term/APKBUILD')
-rw-r--r--testing/ocaml-lambda-term/APKBUILD92
1 files changed, 53 insertions, 39 deletions
diff --git a/testing/ocaml-lambda-term/APKBUILD b/testing/ocaml-lambda-term/APKBUILD
index e22c86b392a..922fd1a07b7 100644
--- a/testing/ocaml-lambda-term/APKBUILD
+++ b/testing/ocaml-lambda-term/APKBUILD
@@ -1,68 +1,82 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=ocaml-lambda-term
_pkgname=lambda-term
-pkgver=1.13
-pkgrel=0
+pkgver=3.2.0
+pkgrel=4
pkgdesc="Terminal manipulation library for OCaml"
-url="https://github.com/diml/lambda-term"
-# x86, armhf, s390x: limited by ocaml aport
-arch="all !x86 !armhf !armv7 !s390x"
+url="https://github.com/ocaml-community/lambda-term"
+arch="all !riscv64 !loongarch64" # ocaml
license="BSD-3-Clause"
-depends="ocaml-camomile ocaml-lwt ocaml-lwt_react ocaml-lwt_log ocaml-zed"
-makedepends="
- dune
- ocaml
+# ocaml-lwt_react-dev is provided by ocaml-lwt-dev
+depends_dev="
+ $pkgname=$pkgver-r$pkgrel
ocaml-camomile-dev
ocaml-lwt-dev
ocaml-lwt_log-dev
- ocaml-findlib
- ocaml-react-dev
- ocaml-result-dev
+ ocaml-mew_vi-dev
ocaml-zed-dev
- opam
"
+makedepends="$depends_dev dune ocaml"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.bz2::https://github.com/diml/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tbz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml-community/lambda-term/releases/download/$pkgver/lambda-term-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+_ocamldir=usr/lib/ocaml
+
+# 32-bit archs
+case "$CARCH" in
+ arm*|x86) options="$options textrels" ;;
+esac
build() {
- cd "$builddir"
- jbuilder build @install
+ dune build --release --verbose
}
check() {
- cd "$builddir"
- jbuilder runtest
+ dune runtest --verbose
}
package() {
- cd "$builddir"
+ dune install --destdir="$pkgdir"
+}
- opam-installer -i \
- --prefix="$pkgdir/usr" \
- --libdir="$pkgdir/usr/lib/ocaml" \
- --docdir="$pkgdir/doc" \
- --mandir="$pkgdir/usr/share/man" \
- $_pkgname.install
+dev() {
+ default_dev
- # There's just a readme and changelog.
- rm -Rf "$pkgdir"/doc
+ cd "$pkgdir"
- # Remove annotation files and sources.
- cd "$pkgdir"/usr/lib/ocaml/$_pkgname
- rm -f *.cmt* *.ml
+ local path; find $_ocamldir \( \
+ -name '*.cmt' -o \
+ -name '*.cmti' -o \
+ -name '*.ml' -o \
+ -name '*.mli' \
+ \) | while read -r path
+ do
+ amove "$path"
+ done
}
-dev() {
- default_dev
- depends="$pkgname=$pkgver-r$pkgrel"
- local sitelib="usr/lib/ocaml/$_pkgname"
+prepare_py_provides() {
+ local datadir="${subpkgdir:-$pkgdir}"
+ local pkgbasedir=${pkgbasedir:-"$startdir/pkg"}
+ local controldir="$pkgbasedir"/.control.${subpkgname:-$pkgname}
+
+ options_has "!tracedeps" && return 0
+
+ ocaml4-abuild-find provides \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir" \
+ "$pkgver-r$pkgrel"
+}
- cd "$pkgdir"/$sitelib
+scan_python3_dependency() {
+ local controldir="$2" datadir="$3"
- mkdir -p "$subpkgdir"/$sitelib
- mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
+ ocaml4-abuild-find requires \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir"
}
-sha512sums="79efc40653e74eb27181b260bc0096238854eb72a61b59c3de3740b01399d9fefa35c0f978d48bbf8097647b6324651207ade022572ef06b460b7b1b001b0dc7 ocaml-lambda-term-1.13.tar.bz2"
+sha512sums="
+46cd46f47c9f34c0a5e096b96e6eec59667b645bf5201140e498e6d4eb9baba8204a2b30b73c4b2f8140e5cf1972a56e3aa485b27bc5ace25b2c368f713ad7c4 ocaml-lambda-term-3.2.0.tar.gz
+"