aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-zarith/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ocaml-zarith/APKBUILD')
-rw-r--r--testing/ocaml-zarith/APKBUILD44
1 files changed, 35 insertions, 9 deletions
diff --git a/testing/ocaml-zarith/APKBUILD b/testing/ocaml-zarith/APKBUILD
index efa04978554..6b48859b8f8 100644
--- a/testing/ocaml-zarith/APKBUILD
+++ b/testing/ocaml-zarith/APKBUILD
@@ -2,20 +2,25 @@
# Maintainer: River Dillon <oss@outerpassage.net>
pkgname=ocaml-zarith
pkgver=1.12
-pkgrel=1
+pkgrel=5
pkgdesc="library implementing arithmetic and logical operations"
url="https://github.com/ocaml/Zarith"
-arch="all !riscv64" # limited by ocaml aport
-license="custom"
-depends="gmp-dev"
-makedepends="ocaml ocaml-findlib ocaml-compiler-libs ocaml-ocamldoc gmp-dev"
+arch="all !riscv64 !loongarch64" # ocaml
+license="LGPL-2.0-only WITH OCaml-LGPL-linking-exception"
+depends="gmp-dev" # zarith is not split into a -dev subpackage
+makedepends="
+ ocaml
+ ocaml-findlib
+ ocaml-compiler-libs
+ ocaml-ocamldoc
+ "
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/Zarith/archive/refs/tags/release-$pkgver.tar.gz"
builddir="$srcdir/Zarith-release-$pkgver"
# 32bit archs
case "$CARCH" in
-armv7|armhf|mips|x86) options="$options textrels" ;;
+armv7|armhf|x86) options="$options textrels" ;;
esac
build() {
@@ -29,10 +34,31 @@ check() {
}
package() {
- mkdir -p "$pkgdir"/usr/lib/ocaml
+ mkdir -p "$pkgdir"/usr/lib/ocaml "$pkgdir"/usr/lib/ocaml/stublibs
OCAMLFIND_LDCONF=ignore make install
- install -Dm644 README.md -t "$pkgdir"/usr/share/doc/"$pkgname"
- install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/"$pkgname"
+ install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname/
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+}
+
+prepare_py_provides() {
+ local datadir="${subpkgdir:-$pkgdir}"
+ local pkgbasedir=${pkgbasedir:-"$startdir/pkg"}
+ local controldir="$pkgbasedir"/.control.${subpkgname:-$pkgname}
+
+ options_has "!tracedeps" && return 0
+
+ ocaml4-abuild-find provides \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir" \
+ "$pkgver-r$pkgrel"
+}
+
+scan_python3_dependency() {
+ local controldir="$2" datadir="$3"
+
+ ocaml4-abuild-find requires \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir"
}
sha512sums="