aboutsummaryrefslogtreecommitdiffstats
path: root/testing/oh-my-zsh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/oh-my-zsh/APKBUILD')
-rw-r--r--testing/oh-my-zsh/APKBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/testing/oh-my-zsh/APKBUILD b/testing/oh-my-zsh/APKBUILD
index de33449e03c..05d60a51840 100644
--- a/testing/oh-my-zsh/APKBUILD
+++ b/testing/oh-my-zsh/APKBUILD
@@ -1,31 +1,31 @@
# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
-# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
-
+# Maintainer: Jacek Pruciak <alpine@juniorjpdj.pl>
pkgname=oh-my-zsh
-pkgver=0_git20180122
+pkgver=0_git20220104
pkgrel=1
-pkgdesc="A delightful community-driven framework for managing your zsh \
-configuration that includes plugins and themes."
+pkgdesc="A delightful community-driven framework for managing your zsh configuration that includes plugins and themes"
url="https://ohmyz.sh/"
arch="noarch"
license="MIT"
depends="zsh powerline-extra-symbols"
subpackages="$pkgname-doc"
options="!check" # no upstream tests
-_gitrev="37c2d0ddd751e15d0c87a51e2d9f9849093571dc"
+_gitrev="31d63ea884e8ef56a40bed8771cdd8d3aec131f9"
install="$pkgname.post-install $pkgname.post-upgrade"
-source="$pkgname-$pkgver.zip::https://github.com/robbyrussell/$pkgname/archive/$_gitrev.zip
+source="$pkgname-$pkgver.tar.gz::https://github.com/ohmyzsh/ohmyzsh/archive/$_gitrev.tar.gz
install-path.patch"
-builddir="$srcdir/"$pkgname-$_gitrev
+builddir="$srcdir/"ohmyzsh-$_gitrev
package() {
install -d "$pkgdir"/usr/share/oh-my-zsh/ \
"$pkgdir"/usr/share/doc/$pkgname/
- chmod 755 $(find . -type d)
- mv * "$pkgdir"/usr/share/oh-my-zsh/
+ find . -type d -exec chmod 755 {} \;
+ mv ./* "$pkgdir"/usr/share/oh-my-zsh/
install -t "$pkgdir"/usr/share/doc/$pkgname/ \
"$pkgdir"/usr/share/oh-my-zsh/README.md
}
-sha512sums="51724f26ff7a59a1c9e517677b4a45750326ac4ad9f6b3579ed009253f3d37dedafd92c7d8e921bb456ae6862259173f8c9ea5fa562ee2a1c829b09f8f49dba0 oh-my-zsh-0_git20180122.zip
-56bcb688489dcf74ba09a2924bd029786273781cf801c990f4ac2ccf53e4d54143f6c59ff49d0fa11189e07f16665ab7329dead0b9853da7bf1480caa419bf15 install-path.patch"
+sha512sums="
+1e6dae9ea56e1644001a65b3aeebcd2a5e4bd4ef6fb2869c2626c582ffeca7dbd63d2d271854ac59c2753cdf36ef3a0f7d7bcc0ffdf10bdacb2d3039b0e40b84 oh-my-zsh-0_git20220104.tar.gz
+1fa69780fdda6103ff70bf46458985d261309673b7d554b0443344e611671d2de640ced887335a9b9cadb1225f88ddca3c8386cb65eb0c92ba6e0b08d8729a6e install-path.patch
+"