aboutsummaryrefslogtreecommitdiffstats
path: root/testing/oil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/oil/APKBUILD')
-rw-r--r--testing/oil/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/testing/oil/APKBUILD b/testing/oil/APKBUILD
index 447c9248c24..c8bfc944917 100644
--- a/testing/oil/APKBUILD
+++ b/testing/oil/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Miles Alan <m@milesalan.com>
# Contributor: Miles Alan <m@milesalan.com>
pkgname=oil
-pkgver=0.9.4
+pkgver=0.21.0
pkgrel=0
pkgdesc="Oil is a new POSIX & bash compatible shell"
url="https://www.oilshell.org"
@@ -15,7 +15,10 @@ subpackages="$pkgname-doc"
source="https://www.oilshell.org/download/oil-$pkgver.tar.gz"
build() {
- ./configure --prefix /usr --with-readline # not a gnu-autoconf script
+ # not gnu autoconf
+ ./configure \
+ --prefix /usr \
+ --datarootdir /usr/share
make
}
@@ -25,5 +28,5 @@ package() {
}
sha512sums="
-7e76c8ef44ce5a93d7196162b791827c315852e20da91ecb0ade5337bfcc25d01671244f8cbfdea14e8fdcdca576eda11c5470917c621cbfce8be4e74d87cdab oil-0.9.4.tar.gz
+6226fba20a7dd53344d4cd710bb5b4ffe65a9cf5413bff965e99af01c161f555c556296aebe2b842376e825c96a0dfc538964d3d1c904e61cab26bb1850ddfdc oil-0.21.0.tar.gz
"