aboutsummaryrefslogtreecommitdiffstats
path: root/testing/oil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/oil/APKBUILD')
-rw-r--r--testing/oil/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/oil/APKBUILD b/testing/oil/APKBUILD
new file mode 100644
index 00000000000..953ecab02d6
--- /dev/null
+++ b/testing/oil/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Miles Alan <m@milesalan.com>
+# Contributor: Miles Alan <m@milesalan.com>
+pkgname=oil
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="Oil is a new POSIX & bash compatible shell"
+url="https://www.oilshell.org"
+arch="all"
+license="Apache-2.0"
+# !check as source has tests, but tagged releases don't
+# !strip as oil binary shows error message otherwise, see: https://github.com/oilshell/oil/issues/47
+options="!strip !check"
+makedepends="readline-dev bash"
+subpackages="$pkgname-doc"
+source="https://www.oilshell.org/download/oil-$pkgver.tar.gz"
+
+build() {
+ ./configure --prefix /usr --with-readline # not a gnu-autoconf script
+ make
+}
+
+package() {
+ make install DESTDIR="$pkgdir"
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}
+
+sha512sums="9229196761bd9100f8166098fd1c9f7e5c96fb9201ad72fd77379cc723d89da0ae5552269a1990628f81d1240ddd7d0259a3855da7b8fcdb72d5d44caa64ab02 oil-0.9.0.tar.gz"