aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openimageio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/openimageio/APKBUILD')
-rw-r--r--testing/openimageio/APKBUILD76
1 files changed, 0 insertions, 76 deletions
diff --git a/testing/openimageio/APKBUILD b/testing/openimageio/APKBUILD
deleted file mode 100644
index 3205c0ea3e8..00000000000
--- a/testing/openimageio/APKBUILD
+++ /dev/null
@@ -1,76 +0,0 @@
-# Contributor: Mark Riedesel <mark@klowner.com>
-# Contributor: Damian Kurek <starfire24680@gmail.com>
-# Maintainer: Damian Kurek <starfire24680@gmail.com>
-pkgname=openimageio
-pkgver=2.2.17.0
-pkgrel=2
-pkgdesc="Image I/O library supporting a multitude of image formats"
-options="!check net" # more than 10% of all tests fail
-url="https://sites.google.com/site/openimageio/"
-# s390x, mips, mips64 has missing dependency ptex-dev
-arch="all !mips !mips64 !s390x"
-license="BSD-3-Clause"
-makedepends="cmake boost-dev tiff-dev openexr-dev bzip2-dev freetype-dev hdf5-dev
- libtbb-dev libtbb ffmpeg-dev giflib-dev libheif-dev
- libraw-dev openjpeg-dev ptex-dev ptex-static ptex mesa-dev libwebp-dev
- qt5-qtbase-dev fmt-dev python3-dev py3-pybind11-dev"
-subpackages="py3-$pkgname:_python $pkgname-dev $pkgname-doc $pkgname-tools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/OpenImageIO/oiio/archive/Release-$pkgver.tar.gz"
-builddir="$srcdir/oiio-Release-$pkgver"
-
-build() {
- local _py_version=$(python3 --version | cut -c 8-11)
- local _iv="ON"
-
- case "$CARCH" in
- aarch64|armv7|armhf)
- _iv="OFF";;
- esac
-
- # fails to build with fortify source enabled
- export CXXFLAGS="$CXXFLAGS -U_FORTIFY_SOURCE"
-
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_SKIP_RPATH=ON \
- -DPYTHON_VERSION=$_py_version \
- -DOIIO_BUILD_TESTS=OFF \
- -DSTOP_ON_WARNING=OFF \
- -DENABLE_iv=$_iv \
- -DINSTALL_FONTS=OFF
- cmake --build build
-}
-
-check() {
- cd build
- ctest -E broken
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-
- mkdir -p "$pkgdir"/usr/lib/cmake
- mv "$pkgdir"/usr/share/cmake/* "$pkgdir"/usr/lib/cmake
-}
-
-tools() {
- pkgdesc="Tools for manipulating a multitude of image formats"
-
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
-}
-
-_python() {
- local pyver="${subpkgname:2:1}"
- pkgdesc="Python $pyver bindings for OpenImageIO image I/O library"
- depends="python$pyver"
-
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python$pyver* "$subpkgdir"/usr/lib/
-}
-
-sha512sums="
-f891a7a79124c4844cc59c01d58d3bdeca5b16b5ba3105f42984095c898f85fcf5cc5a5f4a849c32baca242164041b0960e8aa402771039723910440e4eecaf5 openimageio-2.2.17.0.tar.gz
-"