aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openttd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/openttd/APKBUILD')
-rw-r--r--testing/openttd/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/testing/openttd/APKBUILD b/testing/openttd/APKBUILD
index e6254619fa5..8683114f3eb 100644
--- a/testing/openttd/APKBUILD
+++ b/testing/openttd/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Adrian Siekierka <kontakt@asie.pl>
# Maintainer: Thomas Kienlen <kommander@laposte.net>
pkgname=openttd
-pkgver=1.11.2
-pkgrel=0
+pkgver=13.4
+pkgrel=1
pkgdesc="Open source version of the Transport Tycoon Deluxe simulator"
url="https://www.openttd.org"
arch="all"
@@ -15,22 +15,25 @@ makedepends="
icu-dev
libpng-dev
lzo-dev
+ samurai
sdl2-dev
xz-dev
zlib-dev
"
subpackages="$pkgname-doc $pkgname-lang::noarch"
-source="https://cdn.openttd.org/openttd-releases/$pkgver/openttd-$pkgver-source.tar.xz"
+source="https://cdn.openttd.org/openttd-releases/$pkgver/openttd-$pkgver-source.tar.xz
+ no-sse4.patch
+ "
options="!check" # TODO: find how to start test suite, no check implemented
build() {
cmake -B build \
+ -G "Ninja" \
-DCMAKE_INSTALL_BINDIR=bin \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_DATADIR=share/games \
- -DGLOBAL_DATA_DIR=share/games/openttd \
- -DCMAKE_BUILD_TYPE=None \
- -DReleaseBuild=ON
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS -Wl,-z,stack-size=1048576"
cmake --build build
}
@@ -47,4 +50,7 @@ lang() {
-exec mv {} "$subpkgdir"/{} \;
}
-sha512sums="9a6364bf19627db9f8ec58bfa85fa3a8febf1109f3b5fb9053bef810ac2d0c41df91b58f0b253dd45320a29cae2e8485df794afa7b5240f19759f98fd65c35ea openttd-1.11.2-source.tar.xz"
+sha512sums="
+84f57a39c0dade44f0e6153dff7a40eec0da8e2f892ce870d5f9e037f80daa5c7c46ff786fa51c3671366dd5056504cd7ccbc1c4e5bce8b2c5575533b454c001 openttd-13.4-source.tar.xz
+fef70a685b4d440a0c1a6b6cde94df2dcada7ee10f4b213ee0a649dfbbb5de800aed06a4f066b2be5369147b1ecd83ad6b89bdb06138c46b250ca7f75c95b5a4 no-sse4.patch
+"