aboutsummaryrefslogtreecommitdiffstats
path: root/testing/otpclient/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/otpclient/APKBUILD')
-rw-r--r--testing/otpclient/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/testing/otpclient/APKBUILD b/testing/otpclient/APKBUILD
index 29092e9d011..9e8a052aac4 100644
--- a/testing/otpclient/APKBUILD
+++ b/testing/otpclient/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=otpclient
-pkgver=2.5.1
-pkgrel=0
+pkgver=3.2.1
+pkgrel=1
pkgdesc="Simple GTK+ client for managing TOTP and HOTP"
url="https://github.com/paolostivanin/OTPClient"
license="GPL-3.0-or-later"
@@ -10,20 +10,25 @@ arch="all"
options="!check" # no test suite
makedepends="
cmake
+ gtk+3.0-dev
+ jansson-dev
libcotp-dev
libgcrypt-dev
libpng-dev
+ libqrencode-dev
+ libsecret-dev
libzip-dev
- jansson-dev
+ protobuf-c-dev
+ protobuf-dev
+ samurai
zbar-dev
- gtk+3.0-dev
"
subpackages="$pkgname-doc"
source="https://github.com/paolostivanin/OTPClient/archive/v$pkgver/OTPClient-$pkgver.tar.gz"
builddir="$srcdir/OTPClient-$pkgver"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
@@ -34,5 +39,5 @@ package() {
}
sha512sums="
-121c9b41ba4d658c7273da32d1be705cdeca88160794739959ee63aa53d7e3afcb40e48a2b048a0fdd20f089e2389d6da187be56191a62b6101a2d69abf5d180 OTPClient-2.5.1.tar.gz
+74eb67e93ee2ec9bf780fbe23febd927877073524ad3574034f6b885d3c898a7ec14c2f9771f8368762d76514ca863e84a4ef7cc2db5e7fdeb79de91ee28b2c0 OTPClient-3.2.1.tar.gz
"