aboutsummaryrefslogtreecommitdiffstats
path: root/testing/p910nd/fix-paths.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/p910nd/fix-paths.patch')
-rw-r--r--testing/p910nd/fix-paths.patch16
1 files changed, 5 insertions, 11 deletions
diff --git a/testing/p910nd/fix-paths.patch b/testing/p910nd/fix-paths.patch
index d0d10960c1d..645dee4963f 100644
--- a/testing/p910nd/fix-paths.patch
+++ b/testing/p910nd/fix-paths.patch
@@ -38,30 +38,24 @@ index 2fa4454..a58c1f0 100644
#endif
#ifndef PRINTERFILE
#define PRINTERFILE "/dev/lp%c"
+
diff --git a/Makefile b/Makefile
index 53db51f..6012199 100644
--- a/Makefile
+++ b/Makefile
-@@ -14,12 +14,10 @@ STRIP := strip
- CFLAGS += -O2 -Wall
-
- PROG = p910nd
--CONFIG = p910nd.conf
- INITSCRIPT = p910nd.init
- MANPAGE = p910nd.8
+@@ -18,5 +18,4 @@ STRIP := strip
INSTALL = install
BINDIR = /usr/sbin
-CONFIGDIR = /etc/sysconfig
SCRIPTDIR = /etc/init.d
MANDIR = /usr/share/man/man8
-
-@@ -29,11 +27,10 @@ $(PROG): p910nd.c
+
+@@ -29,11 +29,10 @@ $(PROG): p910nd.c
strip: $(PROG)
$(STRIP) -s $(PROG)
--install: $(PROG) $(CONFIG) $(INITSCRIPT) $(MANPAGE)
+ install: $(PROG) $(MANPAGE)
- mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(CONFIGDIR) \
-+install: $(PROG) $(INITSCRIPT) $(MANPAGE)
+ mkdir -p $(DESTDIR)$(BINDIR) \
$(DESTDIR)$(SCRIPTDIR) $(DESTDIR)$(MANDIR)
$(INSTALL) $(PROG) $(DESTDIR)$(BINDIR)