aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pacparser/spidermonkey-make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pacparser/spidermonkey-make.patch')
-rw-r--r--testing/pacparser/spidermonkey-make.patch16
1 files changed, 9 insertions, 7 deletions
diff --git a/testing/pacparser/spidermonkey-make.patch b/testing/pacparser/spidermonkey-make.patch
index 32bdf053408..1f78fa99b2e 100644
--- a/testing/pacparser/spidermonkey-make.patch
+++ b/testing/pacparser/spidermonkey-make.patch
@@ -3,20 +3,22 @@ over eachother without forcing the copy. This patch adds the -f (force)
option to the find copy command. This is not explicitly needed but does
seem to reduce a warning.
+diff --git a/src/spidermonkey/Makefile b/src/spidermonkey/Makefile
+index 99521a2..1641274 100644
--- a/src/spidermonkey/Makefile
+++ b/src/spidermonkey/Makefile
-@@ -30,12 +30,12 @@
-
+@@ -28,12 +28,12 @@ jsapi: js-buildstamp
+
jslib: js-buildstamp
cd js/src
-- find . -name "libjs.a" -exec cp {} .. \;
-+ find . -name "libjs.a" -exec cp -f {} .. \;
-
+- find . -name "libjs.a" -exec cp {} . \;
++ find . -name "libjs.a" -exec cp -f {} . \;
+
js-buildstamp:
mkdir -p js/src/$(OBJDIR)
- CFLAGS="$(SMCFLAGS)" "$(MAKE)" -C js/src -f Makefile.ref libjs.a
+ CFLAGS="$(SMCFLAGS)" $(MAKE) -C js/src -f Makefile.ref libjs.a
- find js/src -name "jsautocfg.h" -exec cp {} js/src \;
+ find js/src -name "jsautocfg.h" -exec cp -f {} js/src \;
touch js-buildstamp
-
+
clean: