aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pandoc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pandoc/APKBUILD')
-rw-r--r--testing/pandoc/APKBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/testing/pandoc/APKBUILD b/testing/pandoc/APKBUILD
deleted file mode 100644
index 336208fbc35..00000000000
--- a/testing/pandoc/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
-# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
-pkgname=pandoc
-pkgver=2.14.2
-pkgrel=1
-pkgdesc="universal markup converter"
-url="https://pandoc.org/"
-# ghc only supports x86_64
-arch="x86_64"
-license="GPL-2.0-or-later"
-makedepends="ghc cabal zlib-dev zlib-static"
-subpackages="$pkgname-doc"
-source="https://hackage.haskell.org/package/pandoc-$pkgver/pandoc-$pkgver.tar.gz
- cabal.project.freeze
- "
-
-# Cabal seems to be built without sandbox, moving the cabal-dir into src
-export CABAL_DIR="$srcdir/cabal"
-
-prepare() {
- default_prepare
- cp "$srcdir/cabal.project.freeze" . # Created using "cabal freeze"
- cabal update
- cabal configure \
- --prefix='/usr' \
- --enable-tests \
- --enable-split-sections \
- --ghc-option="-split-sections" \
- --ghc-option="-j" \
- --ghc-option="-O1" \
- --flags="+embed_data_files -trypandoc +static"
-}
-
-build() {
- cabal install --only-dependencies
- cabal build
-}
-
-check() {
- cabal test
-}
-
-package() {
- _bindir="$pkgdir/usr/bin"
- mkdir -p "$_bindir"
- cabal install \
- --installdir="$_bindir" \
- --install-method=copy
- install -Dm644 man/pandoc.1 "$pkgdir"/usr/share/man/man1/pandoc.1
-}
-
-sha512sums="
-b6ea6e57fe500d4944d84007c693758a47890ef4880836ccdc7bf5b8d8f3e91c17f05e2d34892e308fdb99bacfa2098065af3d7f18d277f685eff81e810eee17 pandoc-2.14.2.tar.gz
-0ec52a7b1fb421995d843b8135cada2e9fca4030728fd4917a17fadce64830f8f0c9a3e6c51a22ce4da5997378f4ecc72e4f48bae06249c51b0b0b6133247338 cabal.project.freeze
-"