aboutsummaryrefslogtreecommitdiffstats
path: root/testing/paperde/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/paperde/APKBUILD')
-rw-r--r--testing/paperde/APKBUILD50
1 files changed, 34 insertions, 16 deletions
diff --git a/testing/paperde/APKBUILD b/testing/paperde/APKBUILD
index 2279e08218e..922a7b79146 100644
--- a/testing/paperde/APKBUILD
+++ b/testing/paperde/APKBUILD
@@ -1,33 +1,51 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=paperde
-pkgver=0.1.1
-pkgrel=0
+pkgver=0.2.1
+pkgrel=1
pkgdesc="A minimalistic Desktop Environment built on top of Qt/Wayland and Wayfire."
# armhf blocked by extra-cmake-modulese
-# riscv64, s390x and mips64 blocked by polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+# riscv64 and s390x blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
-depends="qt5-qtbase-dev libcprime-dev libcsys-dev wayfire wayland-protocols libdbusmenu-qt-dev qt5-qttools-dev qt5-qtsvg-dev qt5-qtwayland-dev upower-dev xdg-desktop-portal cmake ninja"
-makedepends="qt5-qtbase-dev extra-cmake-modules"
+depends="
+ wayfire
+ xdg-desktop-portal
+ "
+makedepends="
+ dfl-applications-dev
+ dfl-ipc-dev
+ dfl-login1-dev
+ dfl-sni-dev
+ libcprime-dev
+ libcsys-dev
+ libdbusmenu-qt-dev
+ meson
+ qt5-qtbase-dev
+ qt5-qtsvg-dev
+ qt5-qttools-dev
+ qt5-qtwayland-dev
+ samurai
+ upower-dev
+ wayland-protocols
+ wayqt-dev
+ xdg-desktop-portal-dev
+ "
+subpackages="$pkgname-dev"
source="https://gitlab.com/cubocore/paper/paperde/-/archive/v$pkgver/paperde-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
options="!check" # No test suite
build() {
- cmake -B build \
- -GNinja \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DPKGSHAREDPATH=share/paperde \
- -DCMAKE_BUILD_TYPE=None
- cmake --build build
+ abuild-meson . output
+ meson compile -C output
}
-
package() {
- DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="45b1fcd8bc03ae34be7560fe8f369d1bde98da764870298a6f31b8465fd0fc24ace556bf7fadeab756dc4d86115aefc7c8d22eb84602472eeb2c60dc1539b85c paperde-v0.1.1.tar.gz"
+sha512sums="
+e391faec794ccf0d780f7796cadfec3d3a2280e0ee9556b0ba5dfd29db86f5efac168e7b9b6b5f34a54917f0ad8d664723b82910bd2a2b396582d82dd6b0cfce paperde-v0.2.1.tar.gz
+"