aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pastel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pastel/APKBUILD')
-rw-r--r--testing/pastel/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/testing/pastel/APKBUILD b/testing/pastel/APKBUILD
index c79cdce59a1..e99f83f89c1 100644
--- a/testing/pastel/APKBUILD
+++ b/testing/pastel/APKBUILD
@@ -1,23 +1,25 @@
# Contributor: Joe Searle <joe@jsearle.net>
# Maintainer: Joe Searle <joe@jsearle.net>
pkgname=pastel
-pkgver=0.8.1
-pkgrel=1
+pkgver=0.9.0
+pkgrel=2
pkgdesc="A command-line tool to generate, analyze, convert and manipulate colors"
url="https://github.com/sharkdp/pastel"
-arch="all !s390x !mips !mips64 !riscv64" # rust/cargo
+arch="all !s390x !riscv64" # rust/cargo
license="Apache-2.0"
-makedepends="rust cargo"
+makedepends="rust cargo cargo-auditable"
source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/pastel/archive/v$pkgver.tar.gz"
subpackages="
$pkgname-bash-completion
$pkgname-zsh-completion
$pkgname-fish-completion
"
+options="net" # fetch crates
+
build() {
export SHELL_COMPLETIONS_DIR="$builddir/completions"
- cargo build --release
+ cargo auditable build --release
}
check() {
@@ -32,9 +34,9 @@ package() {
install -Dm644 "$builddir"/completions/_pastel \
"$pkgdir"/usr/share/zsh/site-functions/_pastel
install -Dm644 "$builddir"/completions/pastel.fish \
- "$pkgdir"/usr/share/fish/completions/pastel.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/pastel.fish
}
sha512sums="
-a8489ef023f043d0e4153dd151b3f1fb468090570726822f9acf0892e4dd3256d9c2bfe781b3c1260fafb1c05ff9af16cd07c90132c25d6cc29373f660b80160 pastel-0.8.1.tar.gz
+b1dc85062429ca8acda14bec88dcb6057643c1e999582c7e1595ca730312fc8164c558c7459e754cb934a0a1f53ccd8fc542a4ab28dfe05f2f023d223384c464 pastel-0.9.0.tar.gz
"