aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pavucontrol-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pavucontrol-qt/APKBUILD')
-rw-r--r--testing/pavucontrol-qt/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/testing/pavucontrol-qt/APKBUILD b/testing/pavucontrol-qt/APKBUILD
deleted file mode 100644
index c7e9c9d79c0..00000000000
--- a/testing/pavucontrol-qt/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
-pkgname=pavucontrol-qt
-pkgver=0.16.0
-pkgrel=0
-pkgdesc="Pulseaudio mixer in Qt (port of pavucontrol)"
-url="https://github.com/lxqt/pavucontrol-qt"
-arch="all !armhf !mips64" # blocked by liblxqt-dev
-license="LGPL-2.0-or-later"
-makedepends="
- cmake lxqt-build-tools liblxqt-dev
- qt5-qttools-dev pulseaudio-dev
- "
-options="!check" # No testsuite
-source="https://github.com/lxqt/pavucontrol-qt/releases/download/$pkgver/pavucontrol-qt-$pkgver.tar.xz"
-
-build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- $CMAKE_CROSSOPTS .
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-sha512sums="781122b57321cf1e3eff2210e7cb949c819d0148050897d3a9673e846c28fae7a926b4d840c603dac9dace8126bfc49179a737101f4d5b6ad4fe5946d82bd0d5 pavucontrol-qt-0.16.0.tar.xz"