aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-barcode-zbar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-barcode-zbar/APKBUILD')
-rw-r--r--testing/perl-barcode-zbar/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/perl-barcode-zbar/APKBUILD b/testing/perl-barcode-zbar/APKBUILD
new file mode 100644
index 00000000000..26fd135808f
--- /dev/null
+++ b/testing/perl-barcode-zbar/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-barcode-zbar
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Barcode-ZBar
+pkgver=0.10
+pkgrel=2
+pkgdesc="Perl module for Barcode-ZBar"
+url="https://metacpan.org/release/Barcode-ZBar/"
+arch="all"
+license="LGPL-2.1-only"
+depends="perl"
+makedepends="zbar-dev perl-dev"
+checkdepends="imagemagick imagemagick-perlmagick"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/T/TI/TIMLEGGE/Barcode-ZBar-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="
+3d4655133389656288e69612cfd8fbed246802aee4001802d39829b03d8802d6f693ebfd9e454d298861bd7da2f7056a4e7fd616764ac2ffc10c46c046d02182 Barcode-ZBar-0.10.tar.gz
+"