aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-file-mmagic-xs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-file-mmagic-xs/APKBUILD')
-rw-r--r--testing/perl-file-mmagic-xs/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/perl-file-mmagic-xs/APKBUILD b/testing/perl-file-mmagic-xs/APKBUILD
new file mode 100644
index 00000000000..f6adb12b420
--- /dev/null
+++ b/testing/perl-file-mmagic-xs/APKBUILD
@@ -0,0 +1,40 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-file-mmagic-xs
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=File-MMagic-XS
+pkgver=0.09008
+pkgrel=3
+pkgdesc="guess File Type With XS (a la mod_mime_magic)"
+url="https://metacpan.org/release/File-MMagic-XS/"
+arch="all"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DM/DMAKI/File-MMagic-XS-$pkgver.tar.gz
+ format-security.patch
+ "
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="
+82c322f413dabaf916b23d3d829c7ca525d454e00d8f6b7165cef06f70cd1874c45515639e913b06b415864cda3631d34e912b0bd8c85109d2950b7212f8ad05 File-MMagic-XS-0.09008.tar.gz
+31e6543989488f283a31424376a278d87aa11ec367cb0665b5d73690d409902e052fe6b6ac110743a1a2f972e6b9554b5b39287644b22b322dd265de45830a49 format-security.patch
+"