aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-getopt-long-descriptive
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-getopt-long-descriptive')
-rw-r--r--testing/perl-getopt-long-descriptive/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/testing/perl-getopt-long-descriptive/APKBUILD b/testing/perl-getopt-long-descriptive/APKBUILD
index 29036bbb92a..018f9144739 100644
--- a/testing/perl-getopt-long-descriptive/APKBUILD
+++ b/testing/perl-getopt-long-descriptive/APKBUILD
@@ -4,11 +4,11 @@
pkgname=perl-getopt-long-descriptive
_pkgreal=Getopt-Long-Descriptive
pkgver=0.104
-pkgrel=0
+pkgrel=1
pkgdesc="Getopt::Long, but simpler and more powerful"
-url="http://search.cpan.org/dist/Getopt-Long-Descriptive/"
+url="https://metacpan.org/release/Getopt-Long-Descriptive"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-sub-exporter perl-params-validate"
cpanmakedepends="perl-test-warnings perl-test-fatal perl-cpan-meta-check"
depends="$cpandepends"
@@ -16,21 +16,22 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ make
+}
+
+check() {
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}