aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-ldap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-ldap/APKBUILD')
-rw-r--r--testing/perl-ldap/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/perl-ldap/APKBUILD b/testing/perl-ldap/APKBUILD
new file mode 100644
index 00000000000..bda4eb50b2b
--- /dev/null
+++ b/testing/perl-ldap/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-ldap
+pkgver=0.49
+pkgrel=0
+pkgdesc="LDAP client library"
+url="http://search.cpan.org/dist/perl-ldap/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-convert-asn1"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MA/MARSCHAP/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="191f33fdd3b70156699f4620d8d10cca perl-ldap-0.49.tar.gz"