aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-test-file/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-test-file/APKBUILD')
-rw-r--r--testing/perl-test-file/APKBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/testing/perl-test-file/APKBUILD b/testing/perl-test-file/APKBUILD
index 830f9cc529c..d38356070e0 100644
--- a/testing/perl-test-file/APKBUILD
+++ b/testing/perl-test-file/APKBUILD
@@ -1,35 +1,33 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=perl-test-file
-_realname=Test-File
-pkgver=1.443
-pkgrel=0
-pkgdesc="A collection of test utilities for file attributes"
+_pkgreal=Test-File
+pkgver=1.993
+pkgrel=1
+pkgdesc="test file attributes"
url="https://github.com/briandfoy/test-file"
arch="noarch"
-license="PerlArtistic"
-depends=""
-makedepends="perl-dev"
+license="Artistic-2.0"
+depends="perl"
checkdepends="perl-test-utf8"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/B/BD/BDFOY/$_realname-$pkgver.tar.gz"
-builddir="$srcdir/$_realname-$pkgver"
+source="https://cpan.metacpan.org/authors/id/B/BD/BDFOY/Test-File-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="9ad66b3a9dc1c3752a4ec22934db9139ac010ac3237a3de018d4ec4a65ac047f0152ab9e7979a2615412c1af02a1f2dfa0dbfdf5eba5358628b1b443232c45b2 Test-File-1.443.tar.gz"
+sha512sums="
+0e14580a11afc2f3115d5594be226237803ad8e462c314a2b775ca96bf491cfeea84bd90ae92a70c58d3d8fc7c0f21d38b54a58d29dd01a2c082c0cbfecb0aaf Test-File-1.993.tar.gz
+"