aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pgcli/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pgcli/APKBUILD')
-rw-r--r--testing/pgcli/APKBUILD40
1 files changed, 0 insertions, 40 deletions
diff --git a/testing/pgcli/APKBUILD b/testing/pgcli/APKBUILD
deleted file mode 100644
index 7d63aa2b95c..00000000000
--- a/testing/pgcli/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Thomas Boerger <thomas@webhippie.de>
-# Maintainer: Thomas Boerger <thomas@webhippie.de>
-pkgname=pgcli
-pkgver=3.2.0
-pkgrel=0
-pkgdesc="Postgres CLI with autocompletion and syntax highlighting"
-options="!check" # Tests fail
-url="https://www.pgcli.com"
-arch="noarch"
-license="BSD-3-Clause"
-depends="python3
- py3-pgspecial
- py3-click
- py3-pygments
- py3-prompt_toolkit>2.0.0
- py3-psycopg2
- py3-sqlparse<0.5.0
- py3-configobj
- py3-humanize
- py3-wcwidth
- py3-cli_helpers>1.0.0"
-checkdepends="pytest py3-mock"
-makedepends="python3-dev py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/pgcli/pgcli-$pkgver.tar.gz"
-
-check() {
- python3 -m pytest tests
-}
-
-build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="
-f440fadfafb78b4c6db11fd40f1768ac60a191a243126d7848acc3876e4dc222223abe1fb3abd13f8fa6ad5d4f1b1ac754cb3b35137b569e7174058df4548a91 pgcli-3.2.0.tar.gz
-"