aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pgsanity/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pgsanity/APKBUILD')
-rw-r--r--testing/pgsanity/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/pgsanity/APKBUILD b/testing/pgsanity/APKBUILD
new file mode 100644
index 00000000000..b35cde18681
--- /dev/null
+++ b/testing/pgsanity/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=pgsanity
+pkgver=0.2.9
+pkgrel=0
+pkgdesc="Check the syntax of Postgresql SQL files"
+url="https://github.com/markdrago/pgsanity"
+arch="noarch"
+license="MIT"
+# postgresql-dev is needed for ecpg binary
+depends="python3 postgresql-dev"
+makedepends="py3-setuptools"
+source="https://github.com/markdrago/pgsanity/archive/v$pkgver/pgsanity-$pkgver.tar.gz"
+builddir="$srcdir/pgsanity-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="909a12684f386f023e1e1b2ecbd988eba023597509483b467c411690d42fa2da912e8b7634d9ef600ca9a2770f77f02b07bbadb378f50c6c31cc0b8003c9b83b pgsanity-0.2.9.tar.gz"