aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-decimal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-pecl-decimal/APKBUILD')
-rw-r--r--testing/php7-pecl-decimal/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/php7-pecl-decimal/APKBUILD b/testing/php7-pecl-decimal/APKBUILD
index 0bda74a5ffd..7dd8428122a 100644
--- a/testing/php7-pecl-decimal/APKBUILD
+++ b/testing/php7-pecl-decimal/APKBUILD
@@ -2,13 +2,16 @@
pkgname=php7-pecl-decimal
_pkgreal=decimal
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Correctly-rounded arbitrary precision decimal floating-point arithmetic in PHP."
+# Some tests fail until 2.0.0 is released
+# https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/17821#note_140064
+options="!check"
url="https://pecl.php.net/package/decimal"
arch="all !x86 !ppc64le !armv7 !armhf" # mpdecimal missing
license="MIT"
depends="php7-json"
-makedepends="php7-dev re2c mpdecimal"
+makedepends="php7-dev mpdecimal-dev"
source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz
fix-build.patch
fix-test.patch
@@ -26,7 +29,8 @@ build() {
check() {
# waiting upstream release
rm -f tests/Decimal/operators.phpt tests/Number/operators.phpt tests/Rational/operators.phpt
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test PHP_TEST_SHARED_EXTENSIONS=" \
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 TESTS="--show-diff" \
+ test PHP_TEST_SHARED_EXTENSIONS=" \
-d extension=/usr/lib/php7/modules/json.so \
-d extension=modules/$_pkgreal.so"
}