aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-swoole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-pecl-swoole/APKBUILD')
-rw-r--r--testing/php7-pecl-swoole/APKBUILD43
1 files changed, 0 insertions, 43 deletions
diff --git a/testing/php7-pecl-swoole/APKBUILD b/testing/php7-pecl-swoole/APKBUILD
deleted file mode 100644
index f8a2a74e821..00000000000
--- a/testing/php7-pecl-swoole/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php7-pecl-swoole
-_extname=swoole
-pkgver=4.6.4
-pkgrel=0
-pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP."
-url="https://pecl.php.net/package/swoole"
-arch="all"
-license="Apache-2.0"
-depends="php7-json php7-mysqlnd php7-openssl php7-sockets"
-makedepends="php7-dev openssl-dev nghttp2-dev libucontext-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir"/$_extname-$pkgver
-subpackages="$pkgname-dev"
-
-build() {
- case "$CARCH" in
- ppc64le|s390x|x86) export LDFLAGS="$LDFLAGS -lucontext" ;;
- esac
- phpize7
- ./configure --prefix=/usr \
- --with-php-config=php-config7 \
- --enable-mysqlnd \
- --enable-openssl --with-openssl-dir=/usr \
- --enable-sockets \
- --enable-swoole-json \
- --enable-http2
- make
-}
-
-check() {
- # needs extra services to test all suite
- php7 -d extension=modules/swoole.so --ri swoole
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- echo "extension=$_extname.so" > $_confdir/50_$_extname.ini
-}
-
-sha512sums="d93284d8e3129a802da1ed049436cc7c3dbcbe51e105acd4fa6263ab79d331b9bb7b21845934b3809fb68626425372132d04ad0e7a43fd46af0c0a209227eafd php-pecl-swoole-4.6.4.tgz"