aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-swoole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-pecl-swoole/APKBUILD')
-rw-r--r--testing/php7-pecl-swoole/APKBUILD52
1 files changed, 0 insertions, 52 deletions
diff --git a/testing/php7-pecl-swoole/APKBUILD b/testing/php7-pecl-swoole/APKBUILD
deleted file mode 100644
index 8eca5f5c625..00000000000
--- a/testing/php7-pecl-swoole/APKBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php7-pecl-swoole
-_extname=swoole
-pkgver=4.8.6
-pkgrel=0
-pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP 7.4 - PECL"
-url="https://pecl.php.net/package/swoole"
-arch="all"
-license="Apache-2.0"
-depends="php7-curl php7-json php7-mysqlnd php7-openssl php7-sockets"
-makedepends="php7-dev openssl1.1-compat-dev nghttp2-dev c-ares-dev curl-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir"/$_extname-$pkgver
-subpackages="$pkgname-dev"
-replaces="php7-pecl-openswoole"
-
-case "$CARCH" in
- ppc64le|s390x) makedepends="$makedepends libucontext-dev" ;;
-esac
-
-build() {
- case "$CARCH" in
- ppc64le|s390x) export LDFLAGS="$LDFLAGS -lucontext" ;;
- esac
- phpize7
- ./configure --prefix=/usr \
- --with-php-config=php-config7 \
- --enable-mysqlnd \
- --enable-openssl --with-openssl-dir=/usr \
- --enable-sockets \
- --enable-swoole-curl \
- --enable-swoole-json \
- --enable-cares \
- --enable-http2
- make
-}
-
-check() {
- # needs extra services to test all suite
- php7 -d extension=modules/swoole.so --ri swoole
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/50_$_extname.ini
-}
-
-sha512sums="
-1d15f80f92f14d42afe99aac46b57b58d0844ff7083a9de5f12cb5e9685349a5bb8d93c52a6432eee5f5a34e977c11412397be2c27ad6e6bb095432b9a0077bf php-pecl-swoole-4.8.6.tgz
-"