aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-swoole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-pecl-swoole/APKBUILD')
-rw-r--r--testing/php7-pecl-swoole/APKBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/testing/php7-pecl-swoole/APKBUILD b/testing/php7-pecl-swoole/APKBUILD
deleted file mode 100644
index 18484525148..00000000000
--- a/testing/php7-pecl-swoole/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php7-pecl-swoole
-_extname=swoole
-pkgver=4.6.7
-pkgrel=0
-pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP."
-url="https://pecl.php.net/package/swoole"
-arch="all"
-license="Apache-2.0"
-depends="php7-curl php7-json php7-mysqlnd php7-openssl php7-sockets"
-makedepends="php7-dev openssl-dev nghttp2-dev libucontext-dev curl-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir"/$_extname-$pkgver
-subpackages="$pkgname-dev"
-
-build() {
- case "$CARCH" in
- ppc64le|s390x|x86) export LDFLAGS="$LDFLAGS -lucontext" ;;
- esac
- phpize7
- ./configure --prefix=/usr \
- --with-php-config=php-config7 \
- --enable-mysqlnd \
- --enable-openssl --with-openssl-dir=/usr \
- --enable-sockets \
- --enable-swoole-curl \
- --enable-swoole-json \
- --enable-http2
- make
-}
-
-check() {
- # needs extra services to test all suite
- php7 -d extension=modules/swoole.so --ri swoole
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/50_$_extname.ini
-}
-
-sha512sums="
-011e7088952791abb19fdbebf720fd450c41debdb4563fcbe1d95666379d6b38b57b70befcb7ddd904f20e789026f3fb180f4a71ca803390f5d7d0dba716e996 php-pecl-swoole-4.6.7.tgz
-"