aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-swoole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-pecl-swoole/APKBUILD')
-rw-r--r--testing/php7-pecl-swoole/APKBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/testing/php7-pecl-swoole/APKBUILD b/testing/php7-pecl-swoole/APKBUILD
deleted file mode 100644
index bc45f83d40c..00000000000
--- a/testing/php7-pecl-swoole/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php7-pecl-swoole
-_pkgreal=swoole
-pkgver=4.4.8
-pkgrel=0
-pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP."
-url="https://pecl.php.net/package/swoole"
-arch="all"
-license="Apache-2.0"
-depends="php7-openssl php7-sockets"
-makedepends="php7-dev autoconf re2c openssl-dev nghttp2-dev libucontext-dev"
-source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
-builddir="$srcdir"/$_pkgreal-$pkgver
-subpackages="$pkgname-dev"
-
-build() {
- cd "$builddir"
- case "$CARCH" in
- ppc64le|s390x) export LDFLAGS="$LDFLAGS -lucontext" ;;
- esac
- phpize7
- ./configure --prefix=/usr \
- --with-php-config=php-config7 \
- --enable-openssl \
- --enable-sockets \
- --enable-http2
- make
-}
-
-check() {
- # needs extra services to test all suite
- php7 -d extension="$builddir"/modules/swoole.so --ri swoole
-}
-
-package() {
- cd "$builddir"
- make INSTALL_ROOT="$pkgdir"/ install
- install -d "$pkgdir"/etc/php7/conf.d
- echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini
-}
-
-sha512sums="45ca5d78f94003cc10ea35e63ab2bb6aa25ba6c626d55887e0118d6ccfe23bcd325f0cacf80ec3183cb4d1e3384fb0511b901ff1e2d819171256355d570aba50 swoole-4.4.8.tgz"