aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-xlswriter/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-pecl-xlswriter/APKBUILD')
-rw-r--r--testing/php7-pecl-xlswriter/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/testing/php7-pecl-xlswriter/APKBUILD b/testing/php7-pecl-xlswriter/APKBUILD
deleted file mode 100644
index a8c2b63fd92..00000000000
--- a/testing/php7-pecl-xlswriter/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: viest <dev@service.viest.me>
-# Maintainer: viest <dev@service.viest.me>
-pkgname=php7-pecl-xlswriter
-_extname=xlswriter
-pkgver=1.3.7
-pkgrel=1
-pkgdesc="A PHP 7 Extension for creating and reader XLSX files. "
-url="https://pecl.php.net/package/xlswriter"
-arch="all !mips !mips64" # Test failure
-license="BSD-2-Clause"
-depends="php7-common"
-makedepends="php7-dev zlib-dev"
-source="php-pecl-$_extname-$pkgver.tar.gz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir"/$_extname-$pkgver
-
-build() {
- phpize7
- ./configure \
- --enable-reader \
- --prefix=/usr \
- --with-php-config=/usr/bin/php-config7
- make
-}
-
-check() {
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/$_extname.ini
-}
-
-sha512sums="29a3cc1f2e5dcb29a96dcd08110bb2f3cb40bdd1382f3d56456e98a338f4c0d70e109be0b55e5e161548104bef0729773d0d8fc6bdaa126aa3d6573fac0bac2d php-pecl-xlswriter-1.3.7.tar.gz"