aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php8-pecl-memprof/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php8-pecl-memprof/APKBUILD')
-rw-r--r--testing/php8-pecl-memprof/APKBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/testing/php8-pecl-memprof/APKBUILD b/testing/php8-pecl-memprof/APKBUILD
deleted file mode 100644
index 7c7c09e8c51..00000000000
--- a/testing/php8-pecl-memprof/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-pecl-memprof
-_extname=memprof
-pkgver=3.0.1
-pkgrel=0
-pkgdesc="fast and accurate memory profiler that can be used to find the cause of memory leaks in PHP 8 applications - PECL"
-url="https://pecl.php.net/package/memprof"
-arch="all !x86 !armv7 !armhf" # tests fail
-license="MIT"
-depends="php8-common"
-makedepends="php8-dev judy-dev bsd-compat-headers"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver"
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=php-config8
- make
-}
-
-check() {
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/$_extname.ini
-}
-
-sha512sums="
-efc929adf470271844a4a3ac13de238ed0a90bcd97377fc883ab83d1c0c99a7490208aec96dac6774100f3643633aaead116fc51de860484eef27185c5aebdb4 php-pecl-memprof-3.0.1.tgz
-"