aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php8-pecl-swoole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php8-pecl-swoole/APKBUILD')
-rw-r--r--testing/php8-pecl-swoole/APKBUILD52
1 files changed, 0 insertions, 52 deletions
diff --git a/testing/php8-pecl-swoole/APKBUILD b/testing/php8-pecl-swoole/APKBUILD
deleted file mode 100644
index 9eb1a9c7d6c..00000000000
--- a/testing/php8-pecl-swoole/APKBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-pecl-swoole
-_extname=swoole
-pkgver=4.8.2
-pkgrel=0
-pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP 8.0 - PECL"
-url="https://pecl.php.net/package/swoole"
-arch="all"
-license="Apache-2.0"
-depends="php8-curl php8-mysqlnd php8-openssl php8-sockets"
-makedepends="php8-dev openssl1.1-compat-dev nghttp2-dev c-ares-dev curl-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir"/$_extname-$pkgver
-subpackages="$pkgname-dev"
-replaces="php8-pecl-openswoole"
-
-case "$CARCH" in
- ppc64le|s390x) makedepends="$makedepends libucontext-dev" ;;
-esac
-
-build() {
- case "$CARCH" in
- ppc64le|s390x) export LDFLAGS="$LDFLAGS -lucontext" ;;
- esac
- phpize8
- ./configure --prefix=/usr \
- --with-php-config=php-config8 \
- --enable-mysqlnd \
- --enable-openssl --with-openssl-dir=/usr \
- --enable-sockets \
- --enable-swoole-curl \
- --enable-swoole-json \
- --enable-cares \
- --enable-http2
- make
-}
-
-check() {
- # needs extra services to test all suite
- php8 -d extension=modules/swoole.so --ri swoole
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/50_$_extname.ini
-}
-
-sha512sums="
-da250a70d1778b4919061fbca915c5156d16d140c8ecccf0440e78f5eadaadba6a0fa91c6a90751c6dffbe9bf8e45b097d447bdf0b889dbd55766602a63d6f2d php-pecl-swoole-4.8.2.tgz
-"