aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php8-pecl-swoole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php8-pecl-swoole/APKBUILD')
-rw-r--r--testing/php8-pecl-swoole/APKBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/testing/php8-pecl-swoole/APKBUILD b/testing/php8-pecl-swoole/APKBUILD
deleted file mode 100644
index 7e3425fad04..00000000000
--- a/testing/php8-pecl-swoole/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-pecl-swoole
-_extname=swoole
-pkgver=4.7.0
-pkgrel=0
-pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP."
-url="https://pecl.php.net/package/swoole"
-arch="all"
-license="Apache-2.0"
-depends="php8-curl php8-mysqlnd php8-openssl php8-sockets"
-makedepends="php8-dev openssl-dev nghttp2-dev libucontext-dev curl-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir"/$_extname-$pkgver
-subpackages="$pkgname-dev"
-
-build() {
- case "$CARCH" in
- ppc64le|s390x|x86) export LDFLAGS="$LDFLAGS -lucontext" ;;
- esac
- phpize8
- ./configure --prefix=/usr \
- --with-php-config=php-config8 \
- --enable-mysqlnd \
- --enable-openssl --with-openssl-dir=/usr \
- --enable-sockets \
- --enable-swoole-curl \
- --enable-swoole-json \
- --enable-http2
- make
-}
-
-check() {
- # needs extra services to test all suite
- php8 -d extension=modules/swoole.so --ri swoole
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/50_$_extname.ini
-}
-
-sha512sums="
-045f5abfa9d6ed1fa1413df5d4514158b76ccf3afa4175cb6457d862ac91745337280e975d2b830a97cb757d55a2b8d8fcc9cbfb3a92f6f854554708ce94b219 php-pecl-swoole-4.7.0.tgz
-"