aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php8-pecl-xmlrpc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php8-pecl-xmlrpc/APKBUILD')
-rw-r--r--testing/php8-pecl-xmlrpc/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/testing/php8-pecl-xmlrpc/APKBUILD b/testing/php8-pecl-xmlrpc/APKBUILD
deleted file mode 100644
index af4fad7f8f5..00000000000
--- a/testing/php8-pecl-xmlrpc/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-pecl-xmlrpc
-_extname=xmlrpc
-pkgver=1.0.0_rc2
-_pkgver=${pkgver/_rc/RC}
-pkgrel=0
-pkgdesc="PHP 8 extension to write XML-RPC servers and clients - PECL"
-url="https://pecl.php.net/package/xmlrpc"
-arch="all"
-license="PHP-3.01"
-depends="php8-xml"
-makedepends="php8-dev libxml2-dev"
-source="php-pecl-$_extname-$pkgver.tar.gz::https://pecl.php.net/get/$_extname-$_pkgver.tgz"
-builddir="$srcdir"/$_extname-$_pkgver
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=/usr/bin/php-config8
- make
-}
-
-check() {
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff \
- PHP_TEST_SHARED_EXTENSIONS=" \
- -d extension=/usr/lib/php8/modules/xml.so \
- -d extension=modules/$_extname.so"
- php8 -d extension=modules/$_extname.so --ri $_extname
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/$_extname.ini
-}
-
-sha512sums="127ca134c55ab0f1feff2e322c579ed80b7ad797f2df6f7ee46cb64e7b1c2c58e648ff8946552e99e9a19a60f7007d202334aaf7c5ee7c2c9c1e5fc3249b5924 php-pecl-xmlrpc-1.0.0_rc2.tar.gz"