aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php8-phalcon
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php8-phalcon')
-rw-r--r--testing/php8-phalcon/APKBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/testing/php8-phalcon/APKBUILD b/testing/php8-phalcon/APKBUILD
deleted file mode 100644
index 4f3e66d6782..00000000000
--- a/testing/php8-phalcon/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-phalcon
-_extname=phalcon
-pkgver=5.0.0_beta3
-_pkgver=${pkgver/_beta/beta}
-pkgrel=0
-pkgdesc="High performance, full-stack PHP 8.0 framework delivered as a C extension"
-url="https://phalcon.io/"
-arch="all"
-license="BSD-3-Clause"
-depends="
- php8-curl
- php8-fileinfo
- php8-gettext
- php8-mbstring
- php8-openssl
- php8-pdo
- php8-session
- php8-pecl-psr
- "
-makedepends="php8-dev"
-source="php-$_extname-$_pkgver.tgz::https://pecl.php.net/get/$_extname-$_pkgver.tgz"
-builddir="$srcdir/$_extname-$_pkgver"
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=/usr/bin/php-config8
- make
-}
-
-check() {
- # no tests provided
- php8 -d extension=modules/$_extname.so --ri $_extname
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
-
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/$_extname.ini
-}
-
-sha512sums="
-8a2168ba2a4d0a95a44c91900483930f71a99b9f80ee9ae1b77d7b466af3d55a40e9f39c122964195156f89c374a05b04424112585337b0ec32767db39e66974 php-phalcon-5.0.0beta3.tgz
-"