aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php8-spx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php8-spx/APKBUILD')
-rw-r--r--testing/php8-spx/APKBUILD33
1 files changed, 0 insertions, 33 deletions
diff --git a/testing/php8-spx/APKBUILD b/testing/php8-spx/APKBUILD
deleted file mode 100644
index 70be793291b..00000000000
--- a/testing/php8-spx/APKBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-spx
-_extname=spx
-pkgver=0.4.10
-pkgrel=0
-pkgdesc="A simple & straight-to-the-point PHP 8 profiling extension with its built-in web UI"
-url="https://github.com/NoiseByNorthwest/php-spx"
-arch="x86_64"
-license="GPL-3.0-or-later"
-depends="php8-common"
-makedepends="php8-dev zlib-dev"
-source="php-$_extname-$pkgver.tar.gz::https://github.com/NoiseByNorthwest/php-spx/archive/v$pkgver.tar.gz"
-builddir="$srcdir/php-$_extname-$pkgver"
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=php-config8
- make
-}
-
-check() {
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
- php8 -d extension=modules/$_extname.so --ri $_extname
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/$_extname.ini
-}
-
-sha512sums="f89effb851bc9f63e5846b4f8ab998027dfaf214b9111e185fa49dd36377c4ef3d8c98de2f51a7fffca51de7033143f77c5db22a50eb252e1b65d5ebf77a8b16 php-spx-0.4.10.tar.gz"