aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-ast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-ast/APKBUILD')
-rw-r--r--testing/php81-pecl-ast/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/testing/php81-pecl-ast/APKBUILD b/testing/php81-pecl-ast/APKBUILD
index cabb24c9887..d2803ecdf3e 100644
--- a/testing/php81-pecl-ast/APKBUILD
+++ b/testing/php81-pecl-ast/APKBUILD
@@ -3,20 +3,22 @@
# Maintainer: Andy Postnikov <apostnikov@gmail.com>
pkgname=php81-pecl-ast
_extname=ast
-pkgver=1.0.14
+pkgver=1.1.1
pkgrel=0
pkgdesc="PHP extension exposing PHP 8.1 abstract syntax tree - PECL"
url="https://pecl.php.net/package/ast"
arch="all"
license="BSD-3-Clause"
-depends="php81-common"
-makedepends="php81-dev"
+_phpv=81
+_php=php$_phpv
+depends="$_php-common"
+makedepends="$_php-dev"
source="php-pecl-$_extname-$pkgver.tar.gz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
builddir="$srcdir"/$_extname-$pkgver
build() {
- phpize81
- ./configure --prefix=/usr --with-php-config=/usr/bin/php-config81
+ phpize$_phpv
+ ./configure --prefix=/usr --with-php-config=/usr/bin/php-config$_phpv
make
}
@@ -26,11 +28,11 @@ check() {
package() {
make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php81/conf.d
+ local _confdir="$pkgdir"/etc/$_php/conf.d
install -d $_confdir
echo "extension=$_extname" > $_confdir/$_extname.ini
}
sha512sums="
-12cdb4fd864380dba0887b59986a388af49bff782cbea31b71fa0932920a328c8c1d1bda43b23f3b42645cfee38f8198bd739379fa6dc9fc60a89541b52f9336 php-pecl-ast-1.0.14.tar.gz
+a5ae79b4ad4976f2447b94ebc5d3e2d6044ade36c73695ab7f3324963c175a3288d75361e930133232191e8141009d6c0ca8cabfafa143c5dd2282102834eeab php-pecl-ast-1.1.1.tar.gz
"