aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-ast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-ast/APKBUILD')
-rw-r--r--testing/php81-pecl-ast/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/php81-pecl-ast/APKBUILD b/testing/php81-pecl-ast/APKBUILD
new file mode 100644
index 00000000000..d2803ecdf3e
--- /dev/null
+++ b/testing/php81-pecl-ast/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Andy Blyler <andy@blyler.cc>
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php81-pecl-ast
+_extname=ast
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="PHP extension exposing PHP 8.1 abstract syntax tree - PECL"
+url="https://pecl.php.net/package/ast"
+arch="all"
+license="BSD-3-Clause"
+_phpv=81
+_php=php$_phpv
+depends="$_php-common"
+makedepends="$_php-dev"
+source="php-pecl-$_extname-$pkgver.tar.gz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
+builddir="$srcdir"/$_extname-$pkgver
+
+build() {
+ phpize$_phpv
+ ./configure --prefix=/usr --with-php-config=/usr/bin/php-config$_phpv
+ make
+}
+
+check() {
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+ local _confdir="$pkgdir"/etc/$_php/conf.d
+ install -d $_confdir
+ echo "extension=$_extname" > $_confdir/$_extname.ini
+}
+
+sha512sums="
+a5ae79b4ad4976f2447b94ebc5d3e2d6044ade36c73695ab7f3324963c175a3288d75361e930133232191e8141009d6c0ca8cabfafa143c5dd2282102834eeab php-pecl-ast-1.1.1.tar.gz
+"