aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-decimal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-decimal/APKBUILD')
-rw-r--r--testing/php81-pecl-decimal/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/php81-pecl-decimal/APKBUILD b/testing/php81-pecl-decimal/APKBUILD
new file mode 100644
index 00000000000..83f06f702cd
--- /dev/null
+++ b/testing/php81-pecl-decimal/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php81-pecl-decimal
+_extname=decimal
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Correctly-rounded arbitrary precision decimal floating-point arithmetic in PHP 8.1 - PECL"
+url="https://pecl.php.net/package/decimal"
+arch="all"
+license="MIT"
+_phpv=81
+_php=php$_phpv
+depends="$_php-common"
+makedepends="$_php-dev mpdecimal-dev"
+source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
+builddir="$srcdir/$_extname-$pkgver"
+
+install_if="php-$_extname php$_phpv"
+
+build() {
+ phpize$_phpv
+ ./configure --prefix=/usr --with-php-config=php-config$_phpv
+ make
+}
+
+check() {
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+ local _confdir="$pkgdir"/etc/$_php/conf.d
+ install -d $_confdir
+ echo "extension=$_extname" > $_confdir/$_extname.ini
+}
+
+sha512sums="
+06806cb9c5ebae3abed1d41d021be63bb6ab44878e3034c4661a13d22ffab12b9804bc9196c10bdc9416d2559719b31a7fef73e3948c1ea94d3447c6a4b6c086 php-pecl-decimal-1.5.0.tgz
+"