aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-grpc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-grpc/APKBUILD')
-rw-r--r--testing/php81-pecl-grpc/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php81-pecl-grpc/APKBUILD b/testing/php81-pecl-grpc/APKBUILD
new file mode 100644
index 00000000000..f7f095dd533
--- /dev/null
+++ b/testing/php81-pecl-grpc/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php81-pecl-grpc
+_extname=grpc
+pkgver=1.62.0
+pkgrel=0
+pkgdesc="PHP 8.1 extension provide a concrete implementation of the gRPC protocol, layered over HTTP/2."
+url="https://pecl.php.net/package/grpc"
+arch="all !s390x !ppc64le !riscv64" # build failures
+license="Apache-2.0"
+_phpv=81
+_php=php$_phpv
+depends="$_php-common"
+makedepends="$_php-dev openssl-dev>3 linux-headers"
+source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
+builddir="$srcdir"/$_extname-$pkgver
+
+build() {
+ phpize$_phpv
+ ./configure --prefix=/usr --with-php-config=php-config$_phpv
+ make
+}
+
+check() {
+ # Test suite is not a part of pecl release.
+ $_php -d extension=modules/$_extname.so --ri $_extname
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+ local _confdir="$pkgdir"/etc/$_php/conf.d
+ install -d $_confdir
+ echo "extension=$_extname" > $_confdir/50_$_extname.ini
+}
+
+sha512sums="
+f6dc7ae7829bce9d2650afcaa1e609090bc59d9878a7922fbfc41ec56d8cfef6d3bc14560b9f02fa4fc150a2dd6e1b493671078a6a18c0bcec57325dbd3c4c64 php-pecl-grpc-1.62.0.tgz
+"