aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-grpc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-grpc/APKBUILD')
-rw-r--r--testing/php81-pecl-grpc/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/testing/php81-pecl-grpc/APKBUILD b/testing/php81-pecl-grpc/APKBUILD
index bc926b2b15b..f7f095dd533 100644
--- a/testing/php81-pecl-grpc/APKBUILD
+++ b/testing/php81-pecl-grpc/APKBUILD
@@ -1,35 +1,37 @@
# Maintainer: Andy Postnikov <apostnikov@gmail.com>
pkgname=php81-pecl-grpc
_extname=grpc
-pkgver=1.43.0
-pkgrel=1
+pkgver=1.62.0
+pkgrel=0
pkgdesc="PHP 8.1 extension provide a concrete implementation of the gRPC protocol, layered over HTTP/2."
url="https://pecl.php.net/package/grpc"
-arch="all !s390x !ppc64le !riscv64 !mips64" # build failures
+arch="all !s390x !ppc64le !riscv64" # build failures
license="Apache-2.0"
-depends="php81-common"
-makedepends="php81-dev openssl-dev linux-headers"
+_phpv=81
+_php=php$_phpv
+depends="$_php-common"
+makedepends="$_php-dev openssl-dev>3 linux-headers"
source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
builddir="$srcdir"/$_extname-$pkgver
build() {
- phpize81
- ./configure --prefix=/usr --with-php-config=php-config81
+ phpize$_phpv
+ ./configure --prefix=/usr --with-php-config=php-config$_phpv
make
}
check() {
# Test suite is not a part of pecl release.
- php81 -d extension=modules/$_extname.so --ri $_extname
+ $_php -d extension=modules/$_extname.so --ri $_extname
}
package() {
make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php81/conf.d
+ local _confdir="$pkgdir"/etc/$_php/conf.d
install -d $_confdir
echo "extension=$_extname" > $_confdir/50_$_extname.ini
}
sha512sums="
-c10b9671c32c8bef2227e2af891c79c067a1f30a2d8c67768cacc7f62ab17a4127065f6f88650cbcb6a7a3007631ed3ba6e7b17d0cf4e01e0ddad0e766987bf5 php-pecl-grpc-1.43.0.tgz
+f6dc7ae7829bce9d2650afcaa1e609090bc59d9878a7922fbfc41ec56d8cfef6d3bc14560b9f02fa4fc150a2dd6e1b493671078a6a18c0bcec57325dbd3c4c64 php-pecl-grpc-1.62.0.tgz
"