aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-mcrypt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-mcrypt/APKBUILD')
-rw-r--r--testing/php81-pecl-mcrypt/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/php81-pecl-mcrypt/APKBUILD b/testing/php81-pecl-mcrypt/APKBUILD
new file mode 100644
index 00000000000..6c8d070252a
--- /dev/null
+++ b/testing/php81-pecl-mcrypt/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php81-pecl-mcrypt
+_extname=mcrypt
+pkgver=1.0.7
+pkgrel=0
+pkgdesc="Provides PHP 8.1 bindings for the unmaintained libmcrypt - PECL"
+url="https://pecl.php.net/package/mcrypt"
+arch="all"
+license="PHP-3.01"
+depends="php81-common"
+makedepends="php81-dev libmcrypt-dev"
+source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
+builddir="$srcdir/$_extname-$pkgver"
+
+build() {
+ phpize81
+ ./configure --prefix=/usr --with-php-config=php-config81
+ make
+}
+
+check() {
+# rm -f tests/mcrypt_rijndael128_128BitKey.phpt # fails
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+ local _confdir="$pkgdir"/etc/php81/conf.d
+ install -d $_confdir
+ echo "extension=$_extname" > $_confdir/$_extname.ini
+}
+
+sha512sums="
+1b579af868a2db073520437ad6a93513c2591bc865d982dc7926591e712614995148d13bacc1b4b207ddecda4bad219b67010a39ea17e1ec6e180d4fd69182ff php-pecl-mcrypt-1.0.7.tgz
+"