aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-memcached/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-memcached/APKBUILD')
-rw-r--r--testing/php81-pecl-memcached/APKBUILD43
1 files changed, 0 insertions, 43 deletions
diff --git a/testing/php81-pecl-memcached/APKBUILD b/testing/php81-pecl-memcached/APKBUILD
deleted file mode 100644
index 737272f7804..00000000000
--- a/testing/php81-pecl-memcached/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php81-pecl-memcached
-_extname=memcached
-pkgver=3.1.5
-pkgrel=1
-pkgdesc="PHP 8.1 extension for interfacing with memcached via libmemcached library - PECL"
-url="https://pecl.php.net/package/memcached"
-arch="all"
-license="PHP-3.01"
-depends="php81-session php81-pecl-igbinary"
-makedepends="php81-dev zlib-dev libmemcached-dev cyrus-sasl-dev"
-# use PECL source when next release will be tagged https://github.com/php-memcached-dev/php-memcached/issues/477
-_commit="19a02bb5bfaeb520b857a2d64172f7d2a9615fb3"
-source="php-pecl-$_extname-$_commit.tar.gz::https://github.com/php-memcached-dev/php-memcached/archive/$_commit.tar.gz"
-builddir="$srcdir/php-$_extname-$_commit"
-#source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-#builddir="$srcdir/$_extname-$pkgver"
-
-build() {
- phpize81
- ./configure \
- --prefix=/usr \
- --with-php-config=php-config81 \
- --enable-memcached-igbinary \
- --disable-memcached-sasl
- make
-}
-
-check() {
- # Tests require memcached server, basic check
- php81 -d extension="$builddir"/modules/$_extname.so --ri $_extname
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
-
- local _confdir="$pkgdir"/etc/php81/conf.d
- mkdir -p $_confdir
- echo "extension=$_extname" > $_confdir/20_$_extname.ini
-}
-
-sha512sums="477b3db594420c0fb6fe23215f9aba574647f7a82efa811d2082aba0a9c16d3c2b6870bf64081a035510c25e92a92e8dc17b75d7c02ad2fb41694306f600b8fb php-pecl-memcached-19a02bb5bfaeb520b857a2d64172f7d2a9615fb3.tar.gz"