aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-protobuf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-protobuf/APKBUILD')
-rw-r--r--testing/php81-pecl-protobuf/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/testing/php81-pecl-protobuf/APKBUILD b/testing/php81-pecl-protobuf/APKBUILD
index 5e5ff4160de..0438ecebaa2 100644
--- a/testing/php81-pecl-protobuf/APKBUILD
+++ b/testing/php81-pecl-protobuf/APKBUILD
@@ -2,35 +2,37 @@
# Maintainer: TBK <alpine@jjtc.eu>
pkgname=php81-pecl-protobuf
_extname=protobuf
-pkgver=3.19.3
+pkgver=4.26.0
pkgrel=0
pkgdesc="PHP 8.1 extension: Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data - PECL"
url="https://pecl.php.net/package/protobuf"
arch="all"
license="BSD-3-Clause"
-depends="php81-common"
-makedepends="php81-dev"
+_phpv=81
+_php=php$_phpv
+depends="$_php-common"
+makedepends="$_php-dev"
source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
builddir="$srcdir/$_extname-$pkgver"
build() {
- phpize81
- ./configure --prefix=/usr --with-php-config=php-config81
+ phpize$_phpv
+ ./configure --prefix=/usr --with-php-config=php-config$_phpv
make
}
check() {
# Test suite is not a part of pecl release.
- php81 -d extension=modules/$_extname.so --ri $_extname
+ $_php -d extension=modules/$_extname.so --ri $_extname
}
package() {
make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php81/conf.d
+ local _confdir="$pkgdir"/etc/$_php/conf.d
install -d $_confdir
echo "extension=$_extname" > $_confdir/$_extname.ini
}
sha512sums="
-af98ebcd80b8bdff187263517674022f6430808d57e72a7cf2880315254552e82f51b085bc9c4dd7bfc76943d9c1fa04816951fa0711d7cbce6e322727ca8fd1 php-pecl-protobuf-3.19.3.tgz
+7e5cff2b6d2c50b0ca4fe7282bf19fbba3b66071b1e8565798cd8f024ca04f1e5174a1764db7dee07c65838551464ff9c6fa74178d4b2eda7fc66c2529540ec8 php-pecl-protobuf-4.26.0.tgz
"