aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-timezonedb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-timezonedb/APKBUILD')
-rw-r--r--testing/php81-pecl-timezonedb/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/php81-pecl-timezonedb/APKBUILD b/testing/php81-pecl-timezonedb/APKBUILD
new file mode 100644
index 00000000000..5409b3a746c
--- /dev/null
+++ b/testing/php81-pecl-timezonedb/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php81-pecl-timezonedb
+_extname=timezonedb
+pkgver=2024.1
+pkgrel=0
+pkgdesc="Timezone Database to be used with PHP's date and time functions."
+url="https://pecl.php.net/package/timezonedb"
+arch="all"
+license="PHP-3.01"
+_phpv=81
+_php=php$_phpv
+depends="$_php-common"
+makedepends="$_php-dev"
+source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
+builddir="$srcdir/$_extname-$pkgver"
+
+build() {
+ phpize$_phpv
+ ./configure --prefix=/usr --with-php-config=php-config$_phpv
+ make
+}
+
+check() {
+ # Test suite is not a part of pecl release.
+ $_php -dextension=modules/$_extname.so --ri $_extname
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+ local _confdir="$pkgdir"/etc/$_php/conf.d
+ install -d $_confdir
+ echo "extension=$_extname" > $_confdir/40_$_extname.ini
+}
+
+sha512sums="
+09772cdb0d94f8bcf937f075dbcc385b3c5c23657c4442b2ea741bb5dcd8b9898bd23019a2e2319178ffcb62aedd11cbc222ed9d603fba608e0e185a9d5282bc php-pecl-timezonedb-2024.1.tgz
+"