aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-xdebug/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-xdebug/APKBUILD')
-rw-r--r--testing/php81-pecl-xdebug/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/testing/php81-pecl-xdebug/APKBUILD b/testing/php81-pecl-xdebug/APKBUILD
index d66f5479f50..ea5986532ca 100644
--- a/testing/php81-pecl-xdebug/APKBUILD
+++ b/testing/php81-pecl-xdebug/APKBUILD
@@ -4,34 +4,38 @@
# Maintainer: Andy Postnikov <apostnikov@gmail.com>
pkgname=php81-pecl-xdebug
_extname=xdebug
-pkgver=3.1.2
+pkgver=3.3.2
pkgrel=0
pkgdesc="PHP 8.1 extension that provides functions for function traces and profiling - PECL"
url="https://pecl.php.net/package/xdebug"
arch="all"
license="PHP-3.0"
-depends="php81-common"
-makedepends="php81-dev"
+_phpv=81
+_php=php$_phpv
+depends="$_php-common"
+makedepends="$_php-dev linux-headers"
source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
builddir="$srcdir/$_extname-$pkgver"
-provides="php81-xdebug=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php81-xdebug" # for backward compatibility
+provides="$_php-xdebug=$pkgver-r$pkgrel" # for backward compatibility
+replaces="$_php-xdebug" # for backward compatibility
+
+install_if="php-$_extname php$_phpv"
build() {
- phpize81
- ./configure --prefix=/usr --with-php-config=php-config81
+ phpize$_phpv
+ ./configure --prefix=/usr --with-php-config=php-config$_phpv
make
}
check() {
# PECL package has no test suite.
- php81 -d zend_extension="$builddir"/modules/xdebug.so -r 'xdebug_info();'
+ $_php -d zend_extension="$builddir"/modules/xdebug.so -r 'xdebug_info();'
}
package() {
make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php81/conf.d
+ local _confdir="$pkgdir"/etc/$_php/conf.d
mkdir -p $_confdir
# should go after opcache
cat > $_confdir/50_$_extname.ini <<-EOF
@@ -40,10 +44,10 @@ package() {
;xdebug.mode=off
EOF
- install -D -m644 -t "$pkgdir"/usr/share/php81/xdebug/ contrib/tracefile-analyser.php
+ install -D -m644 -t "$pkgdir"/usr/share/$_php/xdebug/ contrib/tracefile-analyser.php
install -D -m644 -t "$pkgdir"/usr/share/vim/vimfiles/syntax/ contrib/xt.vim
}
sha512sums="
-63554545a1c1b94d8503a32d23d70ca16fc82866f9b4191e6f3d026e89e4efdc10974d97f8199c2aa3c0dc0b1f27def9906302e96867cad4e3514b0cc1c5de98 php-pecl-xdebug-3.1.2.tgz
+06096e7a8899e586af8a9a763889546274ef0b520c1b84a1153c704cfdd2f6ff5491c30510da34c0b41169c94fe1f08f27b81535f98162edbb14f1569bd55846 php-pecl-xdebug-3.3.2.tgz
"