aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php81-pecl-xhprof/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php81-pecl-xhprof/APKBUILD')
-rw-r--r--testing/php81-pecl-xhprof/APKBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/testing/php81-pecl-xhprof/APKBUILD b/testing/php81-pecl-xhprof/APKBUILD
index 766693ebfde..9f494e9a110 100644
--- a/testing/php81-pecl-xhprof/APKBUILD
+++ b/testing/php81-pecl-xhprof/APKBUILD
@@ -3,35 +3,40 @@
pkgname=php81-pecl-xhprof
_extname=xhprof
-pkgver=2.3.5
-pkgrel=0
+pkgver=2.3.9
+pkgrel=1
pkgdesc="A Hierarchical Profiler for PHP 8.1 - PECL"
url="https://pecl.php.net/package/xhprof"
arch="all"
license="Apache-2.0"
-depends="php81-common"
-makedepends="php81-dev"
-_assetsdepends="php81-ctype graphviz ghostscript-fonts"
+_phpv=81
+_php=php$_phpv
+depends="$_php-common"
+makedepends="$_php-dev"
+_assetsdepends="$_php-ctype graphviz ghostscript-fonts"
subpackages="$pkgname-assets::noarch"
source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
builddir="$srcdir/$_extname-$pkgver/extension"
-provides="php81-xhprof=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php81-xhprof" # for backward compatibility
+provides="$_php-xhprof=$pkgver-r$pkgrel" # for backward compatibility
+replaces="$_php-xhprof" # for backward compatibility
+
+install_if="php-$_extname php$_phpv"
build() {
- phpize81
- ./configure --with-php-config=php-config81
+ phpize$_phpv
+ ./configure --with-php-config=php-config$_phpv
make
}
check() {
[ $CARCH = s390x ] && rm -fr tests/xhprof_005.phpt # sleeping longer in CI
make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 TESTS=--show-diff test
+ $_php -d extension=modules/$_extname.so --ri $_extname
}
package() {
make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php81/conf.d
+ local _confdir="$pkgdir"/etc/$_php/conf.d
install -d $_confdir
cat > $_confdir/$_extname.ini <<-EOF
extension=$_extname
@@ -42,10 +47,10 @@ package() {
assets() {
pkgdesc="A Hierarchical Profiler for PHP (UI assets)"
depends="$_assetsdepends"
- provides="php81-xhprof-assets=$pkgver-r$pkgrel" # for backward compatibility
- replaces="php81-xhprof-assets" # for backward compatibility
+ provides="$_php-xhprof-assets=$pkgver-r$pkgrel" # for backward compatibility
+ replaces="$_php-xhprof-assets" # for backward compatibility
- local _assetsdir="$subpkgdir"/usr/share/php81/xhprof
+ local _assetsdir="$subpkgdir"/usr/share/$_php/xhprof
install -d $_assetsdir
cp -R "$builddir"/../xhprof_lib $_assetsdir
cp -R "$builddir"/../xhprof_html $_assetsdir
@@ -53,5 +58,5 @@ assets() {
}
sha512sums="
-50ae6fb8d63ac8354b7887daecd1882f33e616cd1ef165b54d51f26fa93d2827f621e89d0d583979c453af5d66a83ddcbf0eb2d462df74ebb422294e601268f4 php-pecl-xhprof-2.3.5.tgz
+38a2609d961d908c6a4b5d1ff2085ffdad4a5f7d277705c826ae19e215660802528d606c5ee052f2e65255a7a85b2a9cb9038f4785c730ec468fc76dc7bcf5de php-pecl-xhprof-2.3.9.tgz
"